Jump to content


Photo

Build 0.65


  • Please log in to reply
18 replies to this topic

#1 binstream

binstream

    Producer

  • Pre-Order
  • PipPipPip
  • 668 posts
  • LocationTomsk, Russia

Posted 10 June 2011 - 04:21 PM

You can download the current development build (version 0.65) from Unigine Online Store:
https://store.unigin...accounts/files/

Changes from 0.64 to 0.65:

* Fixed save/load system
* Increased performance
* Added oil storages (on some maps)
* Decreased oil limit
* Fixed Windows installer (wrong shortcut bug)
* Tuned "Siege" map
* A heap of single player campaign changes (you'll see them as the game will be released)

PS: don't miss the trailer! http://oilrush-game....mander-trailer/

#2 Sandy

Sandy

    Newbie

  • Pre-Order
  • Pip
  • 6 posts
  • LocationSlovakia,Bratislava

Posted 10 June 2011 - 04:46 PM

Once again very good work,thank you for your hard work.I am very happy with this game and also with your progress,btw nice trailer thx :-)

#3 Urfoex

Urfoex

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 322 posts
  • LocationGermany

Posted 10 June 2011 - 05:44 PM

Thank you. :thumbsup:

#4 Vince

Vince

    Newbie

  • Pre-Order
  • Pip
  • 2 posts

Posted 10 June 2011 - 06:44 PM

Great new Release!

But since i installed 0.65 some colored lines appear in the game.
They are connected to the bases, units, guns, wales.
Could you tell me how to turn them off?

Thx and great work!

Vince

#5 binstream

binstream

    Producer

  • Pre-Order
  • PipPipPip
  • 668 posts
  • LocationTomsk, Russia

Posted 10 June 2011 - 07:04 PM

Great new Release!

But since i installed 0.65 some colored lines appear in the game.
They are connected to the bases, units, guns, wales.
Could you tell me how to turn them off?

Thx and great work!

Vince


Press F1 to toggle them.

#6 Crismon

Crismon

    Member

  • Pre-Order
  • PipPip
  • 10 posts

Posted 10 June 2011 - 08:17 PM

I still have problems with QT ...

Cannot mix incompatible Qt library (version 0x40703) with this library (version 0x40702)
launcher_x86.sh: line 5: 16367 Abortito                ./launcher_x86 -config ./../data/launcher/launcher.xml

I try with env "LD_LIBRARY_PATH=$(pwd)/lib ./launcher_x86.sh" but the result is same:

./launcher_x86: error while loading shared libraries: libQtWebKitUnigine_x86.so.4: cannot open shared object file: No such file or directory

Is there a solution?

#7 Ypnose

Ypnose

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 202 posts
  • LocationFrance, At the top of the Eiffel tower

Posted 10 June 2011 - 10:04 PM

This weekend my processor and my GPU will be hot!!

I'm really impressed about your knowledges. Vids are epic, game and benchmarks impressive.
Need more companies like that!
Wanna taste Trance: http://forum.ah.fm Posted Image
ArchLinux| Phenom II X4 955 BE | 8Gb DDR3 1333MHz Corsair + Kingston | Asus GTX460

#8 xaver

xaver

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 33 posts

Posted 10 June 2011 - 10:18 PM

@Crismon
rm libQtCoreUnigine_x64.so.4 ln -s /usr/lib/libQtCore.so.4 libQtCoreUnigine_x64.so.4
rm libQtGuiUnigine_x64.so.4 ln -s /usr/lib/libQtGui.so.4 libQtGuiUnigine_x64.so.4
rm libQtNetworkUnigine_x64.so.4 ln -s /usr/lib/libQtNetwork.so.4 libQtNetworkUnigine_x64.so.4
rm libQtWebKitUnigine_x64.so.4 ln -s /usr/lib/libQtWebKit.so.4 libQtWebKitUnigine_x64.so.4
rm libQtXmlUnigine_x64.so.4 ln -s /usr/lib/libQtXml.so.4 libQtXmlUnigine_x64.so.4

-> Your Qt packages newer that game.... switch to your system packages with syslinks.
Archlinux Package hat code in it, thx to packer for add the feature

I found a funny Bug, i know where opponent will drive :P
Attached File  oilrush.png   630.45KB   65 downloads
Attached File  oilrush1.png   377.24KB   57 downloads

#9 glaasje

glaasje

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 58 posts
  • LocationNederland

Posted 10 June 2011 - 11:02 PM

Ok, thats it.
I need a new laptop.
(i wanna play this game on fullspeed :D)

#10 Crismon

Crismon

    Member

  • Pre-Order
  • PipPip
  • 10 posts

Posted 11 June 2011 - 05:32 AM

@Crismon
rm libQtCoreUnigine_x64.so.4 ln -s /usr/lib/libQtCore.so.4 libQtCoreUnigine_x64.so.4
rm libQtGuiUnigine_x64.so.4 ln -s /usr/lib/libQtGui.so.4 libQtGuiUnigine_x64.so.4
rm libQtNetworkUnigine_x64.so.4 ln -s /usr/lib/libQtNetwork.so.4 libQtNetworkUnigine_x64.so.4
rm libQtWebKitUnigine_x64.so.4 ln -s /usr/lib/libQtWebKit.so.4 libQtWebKitUnigine_x64.so.4
rm libQtXmlUnigine_x64.so.4 ln -s /usr/lib/libQtXml.so.4 libQtXmlUnigine_x64.so.4

-> Your Qt packages newer that game.... switch to your system packages with syslinks.
Archlinux Package hat code in it, thx to packer for add the feature

I found a funny Bug, i know where opponent will drive :P
Attached File  oilrush.png   630.45KB   65 downloads
Attached File  oilrush1.png   377.24KB   57 downloads


Thank you xaver, i have solved!!!

#11 Crismon

Crismon

    Member

  • Pre-Order
  • PipPip
  • 10 posts

Posted 11 June 2011 - 07:05 AM

One crash after 30 minutes:

Saving "environment_evening_rainy" world state to "/home/crismon/.OilRush/save/../profiles/Crismon/save/asad.save" file
OpenAL error: invalid operation
OpenAL error: invalid name
OpenAL error: invalid operation
Received signal SIGSEGV, invalid memory reference
Network shutdown
AL lib: ALc.c:1879: exit(): closing 1 Device
AL lib: ALc.c:1808: alcCloseDevice(): destroying 1 Context(s)
AL lib: ALc.c:1420: alcDestroyContext(): deleting 256 Source(s)
AL lib: ALc.c:1427: alcDestroyContext(): deleting 4 AuxiliaryEffectSlot(s)
AL lib: ALc.c:1818: alcCloseDevice(): deleting 14 Buffer(s)
AL lib: ALc.c:1825: alcCloseDevice(): deleting 16 Effect(s)
AL lib: ALc.c:1832: alcCloseDevice(): deleting 256 Filter(s)

I have a question: will never set up a server where to play
a list of players?

#12 Defense

Defense

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 191 posts

Posted 12 June 2011 - 10:11 AM

Nice to see the launcher fixed (resolution, etc.)...

Is there a plan when we will see the unit follow mode again?

#13 benderchief

benderchief

    Member

  • Pre-Order
  • PipPip
  • 13 posts
  • LocationRouyn-Noranda (Quebec)

Posted 12 June 2011 - 03:17 PM

I tried that new version and I'm very impress. There is also much less game crashs in that one.They are still some "AI glitches" but actualy it's not so bad. Keep good works :)
**Specs**
Proc: Intel Core 2 Extreme QX9650 @ 3.33Ghz
Video: nVidia GTX470 (driver: 290.10)
Memory: 16GB DDR2
OS: Ubuntu 11.10 x64

#14 jcp

jcp

    Member

  • Pre-Order
  • PipPip
  • 13 posts

Posted 12 June 2011 - 10:16 PM

I still have problems with QT ...

Cannot mix incompatible Qt library (version 0x40703) with this library (version 0x40702)
launcher_x86.sh: line 5: 16367 Abortito                ./launcher_x86 -config ./../data/launcher/launcher.xml

I try with env "LD_LIBRARY_PATH=$(pwd)/lib ./launcher_x86.sh" but the result is same:

./launcher_x86: error while loading shared libraries: libQtWebKitUnigine_x86.so.4: cannot open shared object file: No such file or directory

Is there a solution?

Same here, and same solution as I did in the 0.64 build (old launcher).

#15 anubisg1

anubisg1

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 31 posts

Posted 13 June 2011 - 06:35 AM

the linux laucher never worked for me...

./launcher_x64: error while loading shared libraries: libQtWebKitUnigine_x64.so.4: cannot open shared object file: No such file or directory

#16 disi

disi

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 105 posts
  • LocationOut there...

Posted 13 June 2011 - 07:14 AM

Same here, and same solution as I did in the 0.64 build (old launcher).


Just for the sake of it :)
I've seen this error, if you have a mix of qt-4.7.3 and 4.7.2 installed. The upgrade was just recently (May or so), I believe your distribution will fix this soon...

//edit: works fine on Gentoo btw.
+-----------------------------------------------------------------\
| Gentoo ~amd64 on 3.0
| * Intel i7-2820QM CPU @ 2.30GHz
| * 16GB@1333MHz
| * AMD Radeon 6970M
+-----------------------------------------------------------------/

#17 jcp

jcp

    Member

  • Pre-Order
  • PipPip
  • 13 posts

Posted 13 June 2011 - 07:20 AM

I will wait about the upgrade of my old distribution :biggrin:
Portage 2.2.0_alpha38 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.12.2-r0, 2.6.39.1 x86_64)

anubisg1 : exactly.

#18 Setlec

Setlec

    Member

  • Pre-Order
  • PipPip
  • 10 posts

Posted 13 June 2011 - 04:42 PM

Awesome update & release, I'm still bug free.... :tongue:

#19 Serge Kanashchuk (mrred)

Serge Kanashchuk (mrred)

    QA engineer

  • Unigine
  • PipPipPip
  • 113 posts

Posted 14 June 2011 - 05:07 AM

@Crismon
rm libQtCoreUnigine_x64.so.4 ln -s /usr/lib/libQtCore.so.4 libQtCoreUnigine_x64.so.4
rm libQtGuiUnigine_x64.so.4 ln -s /usr/lib/libQtGui.so.4 libQtGuiUnigine_x64.so.4
rm libQtNetworkUnigine_x64.so.4 ln -s /usr/lib/libQtNetwork.so.4 libQtNetworkUnigine_x64.so.4
rm libQtWebKitUnigine_x64.so.4 ln -s /usr/lib/libQtWebKit.so.4 libQtWebKitUnigine_x64.so.4
rm libQtXmlUnigine_x64.so.4 ln -s /usr/lib/libQtXml.so.4 libQtXmlUnigine_x64.so.4

-> Your Qt packages newer that game.... switch to your system packages with syslinks.
Archlinux Package hat code in it, thx to packer for add the feature

I found a funny Bug, i know where opponent will drive :P
Attached File  oilrush.png   630.45KB   65 downloads
Attached File  oilrush1.png   377.24KB   57 downloads


This console command for debugging the AI behavior will be switched off in the final release. Press F1 to switch off.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users