Jump to content


Photo

Build 0.80


  • Please log in to reply
30 replies to this topic

#1 binstream

binstream

    Producer

  • Pre-Order
  • PipPipPip
  • 668 posts
  • LocationTomsk, Russia

Posted 16 September 2011 - 02:28 PM

You can download the current development build (version 0.80) from Unigine Online Store.

Changes from 0.75 to 0.80:

* Massive performance boost (no slowdown even by huge battles)
* Improved network synchronization
* Blocked pause/unpause keys if some window is opened
* Increased AI speed
* Fixed a bug with cannon jerking by applying "Barricade" skill
* Added a scrollbar for the video modes list
* Custom resolution is working properly now
* Multiple fixes in DEB packages for Ubuntu/Debian
* Added RPM packages for Linux (64-bit only for now)
* Steam integration is in progress
  • H2L29, niffPiree, atirage21 and 1 other like this

#2 glaasje

glaasje

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 58 posts
  • LocationNederland

Posted 16 September 2011 - 02:57 PM

Thanks! :D

when will we play a match online? :P

#3 anubisg1

anubisg1

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 31 posts

Posted 16 September 2011 - 02:57 PM

Thanks, great job as usual.

May i ask the details about:

* Multiple fixes in DEB packages for Ubuntu/Debian
* Added RPM packages for Linux (64-bit only for now)

what fixes? can they be backported to the rpms?

why not also 32bit? do you need help or instructions on how to set up a chrooted building enviroment able to build debs and rpms for 32 and 64 bit as well?

#4 atirage21

atirage21

    Newbie

  • Pre-Order
  • Pip
  • 1 posts
  • LocationSlovakia

Posted 16 September 2011 - 04:11 PM

Thank You for supporting of Mandriva Linux and Mageia (RPM packages distributions)

#5 Obi-Wahn

Obi-Wahn

    Newbie

  • Pre-Order
  • Pip
  • 8 posts
  • LocationGermany

Posted 16 September 2011 - 05:06 PM

Wow, this update is a huge improvement! :) On Windows it runs with very high details and Anti-Aliasing and on opensuse it runs with high details without AA. The RPM installation was easily.

#6 Big Poppa

Big Poppa

    Newbie

  • Pre-Order
  • Pip
  • 1 posts

Posted 16 September 2011 - 05:48 PM

Just downloaded the oilrush-bin_0.80_i386.deb package (as well as the data package). After installation, attempting to run the game via oilrush generates the following message: ./launcher_x86 not found.

Checking bin/ reveals the following files:

drwxr-xr-x 2 root root 4096 2011-09-16 10:37 ./
drwxr-xr-x 5 root root 4096 2011-09-16 10:37 ../
-rwxr-xr-x 1 root root 65728 2011-09-16 06:31 launcher_x64*
-rw-r--r-- 1 root root 395736 2011-09-16 06:31 libNetwork_x64d.so
-rw-r--r-- 1 root root 3364136 2011-09-16 06:31 libQtCoreUnigine_x64.so.4
-rw-r--r-- 1 root root 11299472 2011-09-16 06:31 libQtGuiUnigine_x64.so.4
-rw-r--r-- 1 root root 1135552 2011-09-16 06:31 libQtNetworkUnigine_x64.so.4
-rw-r--r-- 1 root root 20602456 2011-09-16 06:31 libQtWebKitUnigine_x64.so.4
-rw-r--r-- 1 root root 296016 2011-09-16 06:31 libQtXmlUnigine_x64.so.4
-rw-r--r-- 1 root root 1203248 2011-09-16 06:31 libRakNet_x64d.so
-rw-r--r-- 1 root root 19071872 2011-09-16 06:31 libUnigine_x64d.so
-rwxr-xr-x 1 root root 4976 2011-09-16 06:31 OilRush_x64d*

It appears the 64-bit files got wrapped up in the 32-bit deb file.

#7 H2L29

H2L29

    Newbie

  • Pre-Order
  • Pip
  • 9 posts

Posted 16 September 2011 - 06:16 PM

many problem on deb's for x86,
i look later...
i think deb build is not realy important, the .run's work fine
Debian squeeze x86
Intel E8400 @ 3GHz
Nvidia GTX 260 1Go

Asus EeePC 1201N
Atom 330 @ 2GHz
NVidia ION 512Mo without Optimus

#8 Yuriy Kolesnikov

Yuriy Kolesnikov

    Newbie

  • Pre-Order
  • Pip
  • 7 posts

Posted 16 September 2011 - 06:23 PM

The download speed is less then 100 kB/s. How about:
  • Creating private torrent tracker (with disabled DHT)?
  • Auto-update feature.
  • Patch support.
  • Any other suggestions?


#9 Vadi

Vadi

    Member

  • Pre-Order
  • PipPip
  • 23 posts

Posted 17 September 2011 - 12:41 AM

Upgrading from the previous versions using .debs doesn't work, I'm not sure if the .deb improvements cover it for future updates - but in case they don't, trying to install the -data package yields this error:
Breaks existing package 'oilrush-x64' dependency oilrush-data (= 0.75)

and trying to install the game package yields this error:
Dependency is not satisfiable: oilrush-data (= 0.80)

#10 miller3492

miller3492

    Member

  • Members
  • PipPip
  • 14 posts

Posted 17 September 2011 - 04:14 AM

game crashes now on start up for windows 7 64 bit

#11 Karkan

Karkan

    Member

  • Pre-Order
  • PipPip
  • 15 posts

Posted 17 September 2011 - 09:15 AM

Yeah!
This build is working for me :sorcerer:

#12 Matthieu

Matthieu

    Newbie

  • Pre-Order
  • Pip
  • 2 posts

Posted 17 September 2011 - 12:13 PM

In your changelog you mention fixes of .deb packages but as other have stated they are now actually broken. I've downloaded them yesterday and after installation I ended up with 64-bit binaries on a 32-bit Ubuntu 11.04 (I've downloaded oilrush-bin_0.80_i386.deb). You also managed to break the menu launcher it points to launcher_x86.sh which doesn't exist anymore so instead of fixes there is total breakage.

#13 F.Ultra

F.Ultra

    Newbie

  • Pre-Order
  • Pip
  • 8 posts

Posted 17 September 2011 - 09:15 PM

That is because they put a version dependency in the oilrush-bin.deb, if they had simply set the dependency to be oilrush-data (instead of oilrush-data(0.80)) then the upgrade would have gone smoother. What you must do as a user to upgrade now is to first uninstall the oilrush-bin package with the software center and then you can upgrade the new oilrush-data and after that install the new oilrush-bin.

The fixes that they mention is probably that they have cleaned up /opt/oilrush which got some extra files and folders installed in 0.75, because these extra files are no longer part of the debs.

#14 maizuddin

maizuddin

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 282 posts
  • LocationKuala Lumpur , Malaysia

Posted 18 September 2011 - 11:32 AM

anyone had problem with the latest version of deb? i remove the oilrush-bin and upgrade it like what F.Ultra said.
but , when I look at the /opt/oilrush file, there is no launcher file etc that can make the game launch
using....
ubuntu 12.04 & windows 7

#15 Matthieu

Matthieu

    Newbie

  • Pre-Order
  • Pip
  • 2 posts

Posted 18 September 2011 - 12:17 PM

F.Ultra sorry to say but you're wrong. Just look what is in oilrush-bin_0.80_i386.deb. You can open it with file-roller for example. You won't find there launcher_x86.sh, file that is linked with menu item (in GNOME or any other DE). Then when you look into /opt/oilrush/bin there are only 64-bits files in a package for 32-bit system. How is that supposed to work.
  • maizuddin likes this

#16 Ypnose

Ypnose

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 202 posts
  • LocationFrance, At the top of the Eiffel tower

Posted 18 September 2011 - 04:54 PM

Hum. Last time I played, it was the 0.66 build and now I am so impressed about your work. The sounds are very realistic and sometimes I am moving on my chair because the badass music is awesome. The Menu is well designed and I love to see some blinks. The perfs are also better. And I feel the game is well polished, too.

Great job from Unigine team :wub:
  • maizuddin likes this
Wanna taste Trance: http://forum.ah.fm Posted Image
ArchLinux| Phenom II X4 955 BE | 8Gb DDR3 1333MHz Corsair + Kingston | Asus GTX460

#17 Shahrizai

Shahrizai

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 40 posts
  • LocationBeijing, China

Posted 20 September 2011 - 04:38 PM

Uhm, this is the first time for me to "get a new build" ... You guys are talking about upgrade... I'm downloading the files now (both of them, like i did the first time (oilrush-bin and oilrush-data). I did not know I could upgrade... So I uninstalled everything first in Ubuntu Software Center.

But my question then: I dont need to uninstall everything for every new build? I can just upgrade? That means, for every new build, I only download .... the oilrush-data? Or both? Or maybe it is best to just always uninstall everything? (I see some people had some problems with upgrading)

#18 binstream

binstream

    Producer

  • Pre-Order
  • PipPipPip
  • 668 posts
  • LocationTomsk, Russia

Posted 20 September 2011 - 05:13 PM

You need both packages. Since there are some problems with DEB/RPM packages, it's better to make clean uninstall/install for now.

#19 Shahrizai

Shahrizai

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 40 posts
  • LocationBeijing, China

Posted 21 September 2011 - 10:35 AM

Aiight, I'll make it a habit :) Like the new build btw :D

#20 anubisg1

anubisg1

    Advanced Member

  • Pre-Order
  • PipPipPip
  • 31 posts

Posted 22 September 2011 - 07:26 AM

the rpm packages seems to work flawless :) so if you have rpm distros (suse, mandriva, fedora, redhat, mageia, ecc ecc) you can go for it :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users